We use cookies to make your experience of our website better. You can delete or block cookies, but some parts of this website won't work without them. By using this website you accept our use of cookies.

ISIS GIS Visualiser Closes immediately with Error must have at least 1 layer

Posted 27/03/2016 06:30 by Tony_Green

Last post 29/03/2016 11:35

1 reply

Whether I have an existing GXY file or not I seem to get the error about needing to have one layer defined and the visualiser closing immediately all the time now (I have many layers defined!).  Before it gave  you a chance to rename layers (if path wrong) or if you deleted the gxy you could re import. Nothing seems to work now and I have tested on several machines (Win7).

Anyone getting the same or have a new workaround?  I suspect something has been updated so it no longer works... not necessarily associated with flood modeller as I have tested on machines without flood modeller installation.

On starting ISIS Mapper I get a message about mapwindow activeX not being registered though if I say ignore the warning it works Ok anyway.  Might be connected.

Bend Loss unit error?

Posted 03/02/2016 12:42 by Hazel Fielding

Last post 03/02/2016 13:33

2 replies

When using a bend loss unit d/s of a junction, I assumed that you could use the remote node option to allow the unit to obtain the upstream velocity from a remote node, but this does not seem to work.  When plotting the velocity for the bend loss unit it just shows the constant initial condition velocity rather than a variable one as is shwon when the bend loss unit is directly d/s of a conduit unit.  Although even using this constant velocity it doesn't appear to be calculating the loss correctly as there should be a small loss (approx. 10mm) but it is showing no loss at all (less than 1mm).  Any ideas?

ISIS Mapper error on opening

Posted 20/07/2015 15:23 by E_Charles

Last post 29/07/2015 17:52

6 replies

I am using ISIS v3.7.2.

ISIS Mapper brings up the following error whether I call it from within ISIS or direct from the .exe:

"GPF v.3.7.0.1216".  

An error has occurred:

__

Expection of type 'System.WIndows.Forms.AxHost

InvalidActiveXStateException' was thrown.

__

If I continue then Mapper opens but if I try to use any features I get the following:

"GPF v.3.7.0.1216".  

An error has occurred:

__

Object reference not set to an instance of an object.

 

Does this indicate something on my system that is not set up quite right or is it a bug of some kind?

 

Lateral Units when using User defined split

Posted 03/01/2015 21:18 by Tony_Green

Last post 07/01/2015 14:49

1 reply

For some reason the isis3 interface (v3.7) has started insisting that all node labels should be called OVERRIDE if using the USER DEFINED distribution method in the LATERAL unit.  This is of course wrong and isisf32 will not accept it and even isis3 objects to it if you try to edit an existing model.  It did not do this in earlier versions...

For now we can manually edit I guessundecided

Forum email bug

Posted 12/12/2014 11:18 by Joe Clarke

No replies yet

Apologies to all users who received an erroneous email for a forum post this morning. The link in the email should have been:

https://www.floodmodeller.com/shared/forums/isis-3/1d/1d-model-building/entering-observed-rainfall-in-refh-boundary

Kind regards,

Joe

mannings within panels

Posted 28/08/2014 15:44 by ParrattL

Last post 16/01/2015 18:14

1 reply

What does ISIS do with different n vaues in one panel. Which does it use for K in a given panel?

Errors when entering data

Posted 27/05/2014 10:12 by tmashby

Last post 28/04/2015 13:19

1 reply

Hi, In the most recent version of Isis I have been getting a lot of errors when I enter data. The one that happened just now ended up with having to use task manager to close Isis down. I was pasting some rainfall data into an FEH boudary, and repeatedly got the error: "Invalid Row Index; GetDataValue error". After clicking OK on this several times I then got an Access violation error. These messages seem to cycle indefinitely. I've also had some similar issues when inputting cross section data and others.

ISIS 2D Crash

Posted 04/12/2013 10:11 by tenmaryjan

Last post 16/12/2013 18:23

4 replies

Hi All, I just wanted to try out the newest version of ISIS 64bit but the 2D module just crashes every single time I start it from the start menu. I am able to run both the 1D and Mapper modules but as soon as I attempt to Create an ISIS 2D project file from the Modelling Toolbox the module returns an error message saying it has stopped working. I am running Windows 7 64Bit. Any ideas why it might be happening? EDIT: I have replicated the same error on 3 different machines using both the 32 and 64Bit versions of ISIS. The operating system: Windows 7. EDIT2: I am able to install ISIS 3.6.1 on all machines and it works flawlessly. Mariusz

error message =?

Posted 11/10/2013 09:13 by Lei Yang

No replies yet

Hi All, I received an error message 'List Index out of bounds' when using Results Extractor. Has anyone experienced this and could give a quick guide? Thanks very much. Lei

FEH BOUNDARY V3.6

Posted 03/10/2013 16:37 by rhodri00

Last post 04/10/2013 13:38

3 replies

I am tryng to run an FEH boundary condition on a model. When all variables are entered and you click the calculated hydrograph tab, ISIS stops working and closes. Any fixes?

Mapper: Fails to open ISIS model

Posted 26/03/2013 12:10 by JuliaLoveless

Last post 02/04/2013 09:45

5 replies

I have a model from ISIS Free. The transects are partially geo-referenced. When I attempt to open this model in ISIS mapper (by clicking selecting the "import isis model" icon) it lets me name the shapefiles and choose whether I want the center line through center or depth. However, when I click proceed an error message pops up saying "data is corrupt or missing files" I was under the impression ISIS could upload partially geo-referenced data, but perhaps I have to geo-reference all of it before it will open the model? UPDATE: Having closed and re-opened ISIS Mapper it now says no error message but the river profile does not appear in the work area or in the layers tab.

XSPROPS.dll

Posted 25/02/2013 11:11 by tom

Last post 26/02/2013 13:10

2 replies

Are there any known issues with running the “Tabulate Cross Section Properties” tool in ISIS 3.6 64bit on Windows 7? I get an error when trying to run the tool saying it cant find the above dll, although the dll does exist, and just want to find out if its a known bug or a system problem at our end.

Legend doesn't show on long section plot

Posted 12/08/2011 11:55 by tmashby

Last post 12/08/2011 16:20

5 replies

Have just noticed that when I try and turn the legend on for a long section plot it doesn't come up. There is a tick next to Legend in the right-click menu. I think this must have happened since I upgraded to the latest version.

Long Section for Steady Results

Posted 03/02/2011 09:23 by Tony_Green

Last post 03/02/2011 12:29

2 replies

I seem to be unable to plot a long section after a steady run only. I feel sure you could before in maybe 3.2?. Workaround is a very short unsteady run which is OK but a pain when checking during model build process Anyone else having the same problem?

ISIS Mapper v3.3 crashing

Posted 10/11/2010 10:40 by u01nwy2

Last post 10/11/2010 11:17

3 replies

When I try to load an Esri ASCII grid in mapper 3.3 the mapper component freezes and is shown as "not responding" in task manager. I can view the grids in v3.4 but wish to do more using the 3.3 components. i am running the correct DirectX (v9.0c)

Mapper does not display images

Posted 02/06/2010 15:29 by MRFrancis

Last post 06/01/2014 06:49

6 replies

Hi, I have just downloaded the ISIS free version including Mapper. I can get Mapper to start up but if I load up an imge (eg OS tif file) it appears to load but nothing is shown in the window. Same result for an ascii grid file. DirectX tests check out OK. Any ideas? Or does it not work with the free version? Many thanks.

Orifice

Posted 19/05/2010 11:40 by JackSouthon

Last post 19/05/2010 11:53

1 reply

Not so much as bug as a small typo. On the open orifice dialogue "Discharge Coefficients" is missing an I. Just noticed while searching help on these values.

TabularCSV command line behaviour ... odd

Posted 09/03/2010 18:09 by hamish.harvey

No replies yet

Two bugs/shortcomings in TabularCSV.exe. I'm using it from the command line to extract results from Isis runs. The instructions at http://www.isisuser.com/faqs/default.asp?ai=38 indicate that the .tcs and .zzn files need to be given in fully qualified, quoted form. I assumed (not really explicitly, it just didn't cross my mind that there would be a problem) that that would not be necessary, and used tabularcsv -silent -tcs mytcsfile.tcs myresultsfile.zzn That ignores the contents of the .tcs file, and gives, I think, all state variables / outputs in default format. Giving the .tcs file in fully qualified, quoted form works - it uses the specification in the .tcs file. Oddly, the .zzn file does not need to be qualified or quoted. Even more oddly, if I omit the -tcs parameter entirely: tabularcsv -silent myresultsfile.zzn the .csv files only contains the stage data. Bug 1: Not being able to understand an unqualified file name for the parameter to the -tcs option. Bug 2: Not giving any feedback to the user if the parameter to the -tcs option is not found. While I'm at it, when running tabularcsv with the -silent switch it still opens its window, very briefly, which can be a nuisance when trying to running it in the background. At best it's a distraction when the task bar keeps flickering. ISISf32_nw doesn't do this (it might also be worth updating the FAQ linked above to use the _nw version, or at least to explain the possibility of using it). Cheers, Hamish

Problem maximising windows

Posted 01/04/2009 13:09 by Fiona

Last post 01/04/2009 15:43

1 reply

I have two monitors, the smaller of which is set up a the main monitor. If I try and maximise ISIS on the smaller monitor it gets the length of the window wrong, so that I cannot see the initial conditions, or bottom of the model. Other than always having ISIS on the larger monitor, is there a fix for this? Fiona

Save dialogue box

Posted 08/01/2009 17:11 by Thulo

Last post 28/04/2015 13:23

1 reply

In version 3.1 a minor nusiance that keeps occurring is the save dialouge box popping up when closing or running the ISIS model, even though no changes have been done. It can get a bit confusing and makes you wonder whether you've actually made any changes to the model at all, especially if you've left the model idling away for a long time.

USBPR pier data

Posted 17/12/2008 12:52 by davidk

Last post 18/12/2008 12:09

1 reply

In v3.1 there seems to be a bug with pier data in the USBPR bridge unit, in that it will not allow a total pier width to be added. When the dat file is opened in a text editor the problem seems to be the pier width value being added in the wrong place in the file. Once editied the pier data is read into the unit correctly in isis and the model will run. I presume this is a suitable work around and there's no other reason for the problem?

Sign in to create or reply to forum posts.

Privacy & Terms

Copyright