We use cookies to make your experience of our website better. You can delete or block cookies, but some parts of this website won't work without them. By using this website you accept our use of cookies.

Monica Macias Jimenez

13/09/2019 10:52:24

Hi there,

I have just installed Flood Modeller v4.5 and when I reopened a project I was previously using I found out that my background tiles were in blue instead of the normal colours for a background mapping. I am aware that this is due to a colour ramp which is set up by default. Previously this colour ramp was used automatically when loading an ascii file but not a tif file. I have always modified this colour ramp but I do not know how to revert to the original colours in the tif file. This question might be silly but I have not found how to do that so far.

Thanks,

Monica

 

 

Bob

Flood Modeller Support

13/09/2019 11:01:12

Hi Monica

Are your background tiles in tiff format? In v4.5, we enabled the 2D solver to write out results in geoTIFF grid format (to enable rotated grids to be displayed as is - without conversion to x-y orientation, i.e. as required for ascii format). Therefore, we also added functionality to load geoTIFF grids to the map view. This included a check to determine if the geoTIFF is a grid or an image type, however it now seems that there are selected image files that are not been recognised as such (including some OS Tiles). Thus, they load as a grid with a default colour ramp applied (which is set to always be blue, i.e. to signify a flood map).

There is a workaround to load your geoTIFF image files. You need to modify the file extension of each image file to either “png” or “jpg”. Note if your geoTIFF also has an associated world file then the file extension of this must also be edited to “pgw” or “jpgw” accordingly. Once this change is made the file should successfully load as an image (without the need to actually convert the files to true png or jpg format).

We've already enhanced the code, so geoTIFF files should automatically load as the correct type in future. This update will be part of the next scheduled release (likely to be later this year). In the meantime, I hope this workaround enables you to continue using your geoTIFF image files.

Regards

Bob

Monica Macias Jimenez

13/09/2019 15:29:22

Hi Bob,

This works perfectly! Thanks for letting me know. I will now recheck the way I receive answers as I did not have an email coming through.

Thanks,

Monica

Sign in to create or reply to forum posts.

Privacy & Terms

Copyright