We use cookies to make your experience of our website better. You can delete or block cookies, but some parts of this website won't work without them. By using this website you accept our use of cookies.

Long-section plots before time zero

Posted 25/07/2019 12:36 by pcross2

Last post 25/07/2019 15:20

1 reply

I have a model that I've been running from -5 hours to 0 hours.  The times series plots look good but the long-section animations don't seem to work correctly - they stick at the initial water level until the last time step (0) and then jump to the results at that time.

Is this a known bug?

OS Tiles display issue

Posted 16/07/2019 07:37 by prabhanjan

Last post 16/07/2019 08:50

1 reply

Hi,

I'm trying to load OS tiles (tif) for background mapping in Floodmodeller 4.5.
Somehow the symbology gets changed automatically. Is there a workaround? or is this a known issue?

Thanks,

Prabhanjan

Batch File Problems

Posted 20/03/2019 17:17 by pcross2

Last post 25/07/2019 15:35

1 reply

The latest batch runner is presenting us with some issues, these are:

  1. There doesn't seem to be a way of reordering IEFs within the batch once they are loaded.
  2. When running multiple FMP / TUFLOW SIMs many seem to fail to start. We assume that this is an issue to do with a shared file that needs to be written by TUFLOW (the DTM XF has been suggested). There used to be a time delay that the user could specify between commencing runs which helped to avoid this. Could it be reinstated?

Many thanks

IEF and IED file issues

Posted 20/03/2019 17:10 by pcross2

Last post 20/03/2019 18:38

2 replies

 Two issues, which might be related.  

  1. If you have an IEF which references more than one IED and wish to delete one IED, pressing delete seems to remove all of the IED rows.
  2. If you open and IEF with more than one IED row and then switch to an IED with fewer rows, the extra rows from the first IEF appear in the second IED - so if you save that IED it will be referencing additional IEDs.

 

Not reading multiple .ied files properly

Posted 07/12/2018 15:23 by Hazel Fielding

Last post 07/12/2018 15:41

3 replies

Hi

I just tried to run a model with two .ied files in the .ief; one for the flows and one for the tide.  It read the flow .ied fine but not the tide one.  The .zzd said it was using it but quite clearly it wasn't.  I then swapped the two .ied files round in the list in the .ief so that the tide one was above the flow one and it worked.

Has anyone else come across this possible bug?

Thanks

Hazel

Supercritical flow at culvert inlet

Posted 06/12/2018 19:00 by IanBentley

No replies yet

We noticed that in some cases the culvert inlet unit switches to outlet control when flow in the culvert is supercritical, which is possibly overestimating the upstream head.  This appears to occur becuase the outlet control equation is based on the downstream velocity and the programs selects whichever method produced the higher upstream head.  If the model is run with the stead-state transcritical solver the culvert flow is at critical depth at its upstream end and the unit switches to inlet control.  Shouldn't inlet control be enforced when the culvert flow is supercritical?

System out of memory

Posted 19/11/2018 14:52 by KevH

Last post 19/11/2018 15:35

2 replies

I sometimes run into a software issue when running Flood Modeller TUFLOW models.  The model initialises and runs fine, but from time to run a stream of messages appear on the far right hand window saying: "Exception of type 'System OutOfMemoryException' was thrown at System.Text.StrignBuilder.ToStrign()".  This sometimes doesn't seem to cause any meaningful problem, but sometimes the whole FM project closes with an error.  Any ideas?  I have lost various long model batches to the issue. 

 

Thanks

Urban ReFH units not saving properly

Posted 30/08/2018 21:39 by jeddere

Last post 31/08/2018 17:45

1 reply

I have an IED file with some standard ReFH units and some with the Urban subdivisions activated.  When I click on Results, I get correct output.  When I save I have no errors, but if I try to reload the file into Flood Modeller (v4.3 or v4.4) I get an error saying "On line: DESIGN DESIGN Line no.: 272" Following which you have to press OK, and then I get "A unit was expected at line 280- "   0" was found instead".  Line 272 does not actual say DESIGN DESIGN, but is contained within the first Urban ReFH unit. 

The file fails to load or run.  When attempting to run a model using the IED file, the zzd provides more useful insight, with a number of errors suggesting that the order of the rows in the .IED file are wrong (such as "arf FLAG must be USER or DESIGN; 0.468 input." and  "Drainage capacity return period,   0.00 must be greater than 1" when I have definately put in 10 for the drainage capacity.  IED files without the Urban ReFH units work fine.

Has anyone else had similar problems/know of a way solution?

Thanks, Mary

 

"Cannot focus a disabled or invisible window"

Posted 03/05/2018 12:04 by warrenvokes

Last post 03/10/2018 17:56

3 replies

 I am attempting to use RATING as the outflow structure for an online pond. However, when I attempt to add a new line to the rating table I receive the following error message pop up "Cannot focus a disabled or invisible window". No line is added to the rating table, instead a line is added to the pond geometry table on the GENERAL tab. This error is repeated on my colleagues PC. 

Has anyone had this problem before and found a solution?

Thank,

Warren 

ReFH2 - Fit to Peak

Posted 25/10/2017 14:55 by Lauren

Last post 27/10/2017 15:10

3 replies

Whenever I use the ReFH2 unit in Flood Modeller and use the 'Fit to Peak' function, it does not perform as expected - i.e. the hydrograph does not peak at the specified value. Is this a known bug? How do others overcome this?

Auto-Interpolate - Georeferencing issue

Posted 07/09/2017 14:21 by Jon Lloyd

Last post 08/09/2017 10:30

1 reply

Hello,

 

I've recently noticed an issue with the Auto-interpolate tool in Flood Modeller. For whatever reason, when using auto-interpolate between two nodes, the easting and northing of the interpolated section does not update. I have tried using the 'fill in missing easting and northing' tool as well as the geo-reference all cross sections and each time the tool fails to update the information in the interpolates. Peculiarly, when you select the auto-interpolated node and move it on the map, the easting and northing automatically update. This leads me to believe that this may be a bug within the auto-interpolate tool and I wonder if anyone has encountered a similar problem / knows any solutions.

 

Many thanks,

Jon

 

Layer draw order not changing the visible map

Posted 15/08/2017 12:35 by Tom

Last post 15/08/2017 15:08

1 reply

 Hi,

I have tried changing the layer order by clicking move to top/bottom but nothing happens. The visible order of the layers remains in the same order as they were loaded into flood modeller. I have tried panning/zooming and clicking refresh but the order has not effect on what I can see.

Is this a bug or am I missing something?

Thanks, Tom

Changing Adobe Flash settings to visualise Flood Viewer projects in web browsers

Posted 07/06/2017 15:53 by Bob

No replies yet

 

Some users have reported problems visualiing their Flood Viewer projectsin their web browser. This is actually due to recent changes in Adobe Flash. The Adobe default security settings no longer allow local content, i.e. content created on your machine such as a Flood Viewer project, to load automatically. To get around this issue you need to access and change the Adobe Settings as follows:

  1. In internet Explorer (or probably any browser you use to open your Flood Viewer project), while you are trying to load a Flood Viewer project, right-click on the centre of the page. You should see an Adobe menu. Select "Global Settings".

  2. You should see a new window pop-up after a few seconds, entitled Flash Player Settings Manager. Select the "Advanced" tab

  3. Next click the button called "Trusted location settings". This will display another window that allows you to add files or folder names to a list of local places that Adobe will allow data to be loaded from. Use the Add button and then Add Folder button to browse to your Flood Viewer project location and add this folder to the list. Note that you can add a higher folder as Adobe should then accept anything in any sub-folders from this (although I'm not sure going as high as the entire C-drive would always work - you can always try it to see).

  4. After making the above changes to settings close down all the Adobe Settings windows and then refresh the Flood Viewer page in your browser. Hopefully it will then load successfully after a few seconds.

Unfortunately this is the only way to get current Flood Viewer projects to load on newer systems running the updated Adobe. As a consequence of the Adobe changes we are currently looking at modifying Flood Viewer so hopefully the above process won't be required in future.

I hope this information is useful.

Regards

Bob

ReFH2 unit not saving user comments

Posted 26/05/2017 09:18 by miguel piedra

Last post 27/07/2017 16:44

1 reply

Hello,

I am building a number of ReFH2 units in FM. The user comments I am adding in the unit text boxes dissappear when I close the unit, even when I save the network.

Has anyone else encountered this issue? I am unsing FM v4.2

Many thanks

Miguel

fmpx file associations and user interface glitch

Posted 07/12/2016 14:31 by fiona

Last post 07/12/2016 14:52

1 reply

My computer has file assocations with flood modeller project (fmpx) files and flood modeller so that if I double click on a .fmpx file flood modeller lauches.  However flood modeller doesn't seem to read in the .fmpx file if I do this as it opens to a new empty project.  If I then open the .fmpx file everything seems to open normally, but if I try to view the 2d run .xml files they appear blank in the user interface (except a comment at the bottom saying "Successfully loaded xml model....").  The files are fine when viewed in a text editor and can be viewed normally in the user interface if I close it down and reopen it normally (i.e. without double clicking on the .fmpx file).  It would be useful if flood modeller could load an .fmpx file on launch, and more relaxing if it didn't try and fool you into thinking that you'd somehow manage to delete the contents of someone else's run file....

Multi domain models - link vector spans 2 domain error

Posted 07/12/2016 14:00 by fiona

Last post 07/12/2016 16:23

2 replies

I've got a model with a very narrow channel which I'm trying to model with separate LB and RB domains to prevent flow accross the channel in the 2d domain.  Unless I clip the DTM hard to the active area the model fails to initialise with the error message "ERROR: link vector spans 2 domains - stopping."  Link lines are snapped to the edge of the lb and rb active areas, and do not cross the channel, so it appears that this check is being carried out against the input DTM rather than the active area. Although there is an obvious work around here this makes building multi domain linked models harder than it needs to be as if you change the location of the link lines and the active area, you then need to reclip the DTM which is an extra step which might need to be carried out multiple times in a model build.  Also for 2d only models I've seen instances of flow round the edges of the active area when the DTM has been clipped to the active area extent (cells round the domain edge with 0 m elevation) so there are potential problems with clipping hard to the DTM too.  Is there a better work around? or is is posible to change this check so that it uses the active area shapefile from each domain rather than the DTM?

Viewing saved changes

Posted 06/12/2016 15:41 by SteveL

Last post 06/12/2016 16:28

1 reply

I have a very strange problem.  I have one user who is making changes to files, saving them, but when they re-open them none of the changes have been saved.  The program throws up no error messages on opening, saving or exiting.

 

Any ideas anyone?  Unfortunately I'm new to supporting this software and the users don't know what could be causing the issue.  A full uninstall and re-install didn't correct the problem.

Map not reflecting layer order change

Posted 01/11/2016 16:27 by apeech

Last post 01/11/2016 18:27

1 reply

When I try to adjust the order of layers, it makes no difference to the actual visual display of them.

 

Any ideas?

Saving 1D Network

Posted 17/10/2016 18:04 by Carlos

Last post 18/10/2016 13:55

2 replies

I have a series of ditches (which I'm modeling as river cross sections) and connecting culverts, many branches that are inter-connected. I load the ditch sections using a ".sec" file, but when I go to save the network (to save my progress), without fully connecting the entire network and setting boundary conditions, I get an error (see below). This happened all every time, if I close the program and reopen, then I need to start all over again...load my sections, etc. Why would this happen?

"Flood Modeller - Error happened when saving network: Catastrophic failure (exception from HRESULT: 0x8000FFFF (E_UNEXPECTED))"

 

 

conversion from HEC-RAS

Posted 07/09/2016 12:04 by Hazel Fielding

Last post 07/09/2016 15:43

1 reply

Hi, I've been using the new conversion tool from HEC-RAS to FMPro and it kind of works but it seems to get a bit confused if there are lots of reaches as it doesn't always seem to pick them all up.  I've managed to get round it by editing the original files to limit them to only a few reaches and it seems to work OK but it would be good if that bug could be fixed in future

Thanks

Flood Modeller won't open.

Posted 24/08/2016 09:54 by BenGlover1

Last post 11/10/2016 11:26

6 replies

Hi,

I have just been given a new PC at work and am trying to reinstall Flood Modeller. It seems to install ok and everything completes, but when I go to open it it will not get past the loading screen. Trying to 'jump start' it with an existing model also doesn't work.

Windows 7 Proffesional 64-bit

Flood Modeller 4.2 (or 4.1.1 neither works)

 

Is there some kind of startup log I can look at to see why it won't open, I need access asap.

Regards,

Ben

2d sim status not showing windows 10

Posted 07/07/2016 22:15 by apeech

Last post 24/08/2016 15:51

7 replies

I recently upgraded to windows 10 x64. Flood Modeller seems to work fine so far.

One issue I found is that when I run a 2D sim, there is no display showing how the 2D sim is running (percent complete, volume, link flow etc.). All that shows is the DOS style window with a white section below it. Is this something on my end, or is this known to not display with Windows 10?

Saving project with relative path.

Posted 06/04/2016 11:06 by BenGlover1

Last post 29/08/2017 15:18

5 replies

Just wondering if there are any updates on adding this feature to the program?

3D viewer

Posted 15/03/2016 13:22 by mike.vaughan

Last post 20/06/2016 09:02

3 replies

Hi - anyone having problems with this? i cant get it to load - simply wont and claims itself that its stopped working!

Sign in to create or reply to forum posts.

Privacy & Terms

Copyright