We use cookies to make your experience of our website better. You can delete or block cookies, but some parts of this website won't work without them. By using this website you accept our use of cookies.

Z line ignored in v4.5?

Posted 12/07/2019 11:20 by A FloodModeller

Last post 12/07/2019 15:42

1 reply

Hi all!

I've recently upgraded to Flood Modeller v4.5 and I'm experiencing some difficulties with zlines. I'm sure I've entered them correctly, with an attribute named "elevation". The model runs through without any issues, but when I looked into the 2D log file, I found the following warning:

WARNING: conflicting elevation data in shapefile ISIS 2D Z line - ignoring this shape.

Any ideas what could be going wrong?

Thanks in advance!

Green-Ampt Infiltration setup

Posted 18/06/2019 17:49 by john D

Last post 25/07/2019 15:49

2 replies


Im trying to setup Green-Ampt infiltration for a 2d simulation. I have previously ran the simulation with user entered rainfall successfully. However, when I tried to incorporate green-ampt infiltration i run into the error " ERROR: Problem reading hydrology source details at (origonal shape file used for user entered rainfall) EXITING. Note no spatial diagnostic to output".

The loss shapefile is a simple polygon drawn with the FM GIS tools with added attribute "GA_INDEX"


Due to these points i assume that the problem is with the lookup table which is a .txt file set out like shown beneath with Field 1 followed by spaces to make up to 10 characters and also the following values followed by spaces to make up to 10 characters. I have also tried the lookup table flipped with the Field 1... at the top of each column

Field 1   1         2             

Field 2   0.5       0.6


Problems with setting up roughness from a mastermap shapefile.

Posted 15/06/2019 22:12 by JAlton

Last post 19/06/2019 15:35

7 replies


I am trying to use a mastermap greenarea shape file for roughness in a 2d simulation. Currently, im running into a problem when i try and start the simulation: "WARNING: multi-part polygons present in file (path to shp file) - these are not fully supported..."

So far i have:

edited the original shp file to include a column called "DescGroup" with descriptions for each row e.g. grassland.

Created a .fric text file with the descriptions from the shp file and roughness coefficients.


Thanks for your time, Josh

Oscillating flow line result

Posted 12/06/2019 11:52 by Thomas

Last post 12/06/2019 16:33

2 replies


Hello Flood Modellers!

I set up a 2D-model using flood modeller free (V4.4) of a rather plain valley (1x1 m DTM) and applied a synthetical inflow (trapezoid-shaped, see LINK).

Using a manning roughness value of 0.1 (for high grass, weedy) I get as a resulting flow line (120 m downstream profile) a nearly perfect match
of my inflow curve (green line, see LINK).

When I change nothing but the manning overall roughness value to 0.033 I get a rather weird curve with peaks,
much higher than the inflow (green line, see attachment).

Anybody got a explanation for that, or a way to solve this?
Also with other models I experienced these oscillating flow lines when applying
lower roughness values, even only on parts of the topography.

Any help appreciated! Thank you and best regards!


Dam Breach

Posted 05/06/2019 08:15 by Ioannis T

Last post 24/06/2019 14:41

1 reply

Hi everyone.

Currently I am trying to set up a 1D and a 2D dam breach models. However, I am a bit confused about the way. In my case, it is a concrete dam which means a sudden breach triggered by a specific water elevation (no orifice). The u/s boundary condition is only a hydrograph where no reservoir (pond) is designed into the models. There is only one reach.


For the 1D model:

1) I have the cross sections but, how should I model the dam? As a weir, a breach or a combination of these two?

2) How can I link these features in my 1D model?


For the 2D model:

3) Is there any way to directly model the dam in 2D?

4) Should I create firstly the 1D model and then link it to the 2D?


Any guidlines/suggestions would be highly appreciated, since the procedure is not that clear for me.

Thank you so much for your time and help in advance.


Kind regards,


I have problem in 2d window after the update

Posted 09/05/2019 14:15 by MOHAS

Last post 13/05/2019 09:57

5 replies

Hi dear
I have a problem after updating the program became the last implementation window2D is more complicated There are a lot of additions I do not know how to deal with them when I start the implementation is the exit in the form of a window and a link is different from the previous director, which was the data are called to be in the form of water covering the region Do you have information About how to handle the window and its requirements

Visualization of calculations

Posted 25/04/2019 15:36 by Thomas

Last post 09/05/2019 14:46

7 replies

Hello Flood Modellers out there!


One question concerning the visualization of my 2D calculations (using Flood Modeller Free):

After getting results from a 2D-model, is there any chance to get a sort of smooth waterline or smooth outlines of zones with same depth (instead of the „pixel-like“ representation)?

Many thanks in advance & best regards!


Linked 1D-2D model run won't initialise

Posted 05/02/2019 12:12 by Niamh O'Malley

Last post 07/02/2019 16:22

12 replies

I have created a linked 1D-2D model. The 1D model runs without any problems (that I am aware of anyway). When I try to run the linked model the simulation screen opens but then the model doesn't initialise (i.e. nothing further happens even after leaving it open for an hour). The .xml file is the only file created. I have looked at the xml file and there is nothing obvious to me that is causing the problem. I have checked my link lines and the DTM as well and can't see where the problem is. Any suggestions would be appreciated.



Problems with creating cross sections from ASCII file...? (Flood Modeller Free)

Posted 11/10/2018 14:08 by mcraig_lk

Last post 11/10/2018 15:23

1 reply

Some help required please...

I'm having some issues with creating cross sections from an ASCII grid from my DTM.

I have successfully uploaded the DTM, and have drawn the polyline shapefile to show the channel.

I have also managed to create cross sections along the river, and have uploaded the ASCII grid to define ground elevation levels.

However, when I have tried to create cross section data at each node using the ASCII grid, the data appears to be incomplete - there are only three data points at each location, which creates a shallow and perfectly triangular channel shape. Obviously this is incorrect, as the DTM I have is at a 1m resolution, and using the profile tool on QGIS there is definitely plenty of detail on the actual cross section.

Is there something I'm missing here, or is this an issue with the free version of FloodModeller?

Thanks for any help.

2D simulation error - 'index is out of range. must be non-negative...'

Posted 04/08/2018 10:23 by Ben W

Last post 14/08/2018 10:34

3 replies

Hi Guys, 

Using Flood Modeller Free, I've built a 1D network with multiple culverts throughout the reach and want to investigate culvert blockages. I've successfully ran all 1D unsteady simulations for multiple return periods and culvert blockage percentages.  I've also ran multiple 2D simulations (ADI solver) linked to the 1D simulation with Level/HX links, which run successfully during all return periods. However, when higher percentages of blockages (e.g. 90%) are implemented during some of the culverts, the 2D simulation 'output' window goes blank and I receive the following error: "Index is out of range. must be non-negative and less than the size of the collection." Does anyone have an idea what this error code means and which parameters require changing to fix this error?




2D Flood Extents Export to ShapeFile different from Flood Modeller Displayed Results

Posted 05/02/2018 12:26 by Niamh O'Malley

Last post 06/02/2018 19:01

2 replies

Hi All,

Looking for some help. I have built a linked 1D-2D model to assess the impact of a new road on the existing flood extents. When I display the maximum flood extents in Flood Modeller everything looks as it should base on the levels of the new road but when I export it to a shape file so I can map the results in Autocad it shows more flooding in a number of locations. Does anyone know why this may be occuring?? In one location I know it definitely shouldn't flood based on the ground levels in that location. Has anyone else experienced this?



2D free version question

Posted 30/10/2017 09:29 by cristiantetelea

Last post 30/10/2017 12:02

3 replies

Hi, I am insterested if the the limitation of the free software version (e.g. 100,000 2d cells) reffers to the number of the cells of the ASCII file used as DEM or just the 2d mesh cells created by the Flood Modeller?

2D Direct Rainfall Analysis - Works with version 4.0 but not 4.2 and 4.3

Posted 27/10/2017 12:58 by Niamh O'Malley

Last post 06/11/2017 11:28

2 replies

I have been trying to do a pluvial analysis using a 2D surface, setting up an active area and apply a global depth of rainfall to run the simulation using the FAST solver. I have the latest version 4.3 on my PC and no matter what I do I can't get it to generate a result file. My colleague who has version 4.0 uses the same process as me and can generate the results no problem. I don't really want to install the older version just for this simple exercise. Does anyone have any thoughts on how to get it to work in version 4.3?


Error in 1D model during linked 1D-2D simulation with addition of "topographic feature"

Posted 03/08/2017 10:12 by warrenvokes

Last post 03/08/2017 12:20

1 reply

I have functional 1D-2D model with additional topographic features in the form of polylines that represent walls and bunds. However in attempting to add another topographic feature to the simulation (another polyline), the simulation encounters an error "ERROR: Error in 1D model - check .ZZD file for details. EXITING." The 1D .zzd states:

Poor model convergence at time 3.036 hrs.
Time= 3.036 hrs QRATIO= 5.60 at 9.002I HRATIO= 0.292E-01 at 20.000
MAX DQ= 0.105E-01 at ST04SPUS MAX DH= 0.176 at 20.000

"Model time 3.0361 hrs:
*** error E1020 *** at label: 20.000

Water level exceeded maximum section data level dflood ( 3.00m)
Check model, extend section data or increase dflood
Check model, extend section data or increase dflood
stopped in ondam"

I have encountered this before and been able to fix it by altering the polylines vertex’s slightly. On this occasion is not practical due to the much greater number of vertexes I am dealing with. The polylines attributes are as follows:

Type/ID 0

height1 [D] 100.000                  

height2 [D] 100.000                  

linelabel [S]       -

isis2d [S]           -                                                          

thick [D] 10.000


Has anyone else encountered/found a solution to this? Is my polyline conflicting with something?




Error - Unable to load all selected layers of 2D results file: Insufficient memory available

Posted 20/07/2017 12:49 by warrenvokes

Last post 20/07/2017 14:42

1 reply

Repeatedly recieve the "Error - Unable to load all selected layers of 2D results file: Insufficient memory available" when atemping to view 2D results. 9hours simulation, saving every 2minutes. What memory is this refering to? RAM? Should 16GB of RAM not be sufficent?

Also there is just over 410GB available on my local hard disk.

I would greatly appreciate finding out if anyone has incountered this problem and resloved it.


(Flood Modeller Newbie!) ISIS & TUFLOW to model river flows

Posted 19/07/2017 08:52 by Hannahp

Last post 21/07/2017 18:13

2 replies

Hi all, I have recently downloaded the Environment Agency's Product 7 data- original EA model of fluvial flood height and flow in order to run them myself for a  small watercourse that hasn't had the flow data extracted for it yet due to its size. I have measured the network of nodes to be 520 but only 250 are permitted for my version of Flood Modeller Free. Any way to easily remove unwanted data to bring the network down to the required size? Also any other helpful hints/tips/experience would be greatly apreciated, Many thanks HP 

Export Flood Map

Posted 31/01/2017 16:21 by Juan Pinos

Last post 31/01/2017 17:02

3 replies

I obtained the flood maps of my 2D and 1D models in Flood Modeller Free, now I need to export them to a raster format file for using it in a GIS software. Also when I make zooming to the flood map, the map have blank lines between pixels (please check the image in the link). Help with this issue.



Roughness Values

Posted 14/11/2016 14:40 by Ioannis Tsitroulis

Last post 22/01/2018 18:23

8 replies


I am having a similar problem to you with regards specifying the roughness values from a shapefile. I have created a shapefile with different areas specified as differnt roughnesses in a value field. I load this into Flood Modeller, but then the lookup table stays greyed out. Any ideas as to why this is happening?

Thanks in advance,


1D Network File

Posted 11/08/2016 12:31 by mhkabir

Last post 11/08/2016 14:03

4 replies

My name is Humayain Kabir, a post-graduate student of Climate Change at the University of East Anglia, UK. I am doing my dissertation on 'Flood risk modelling of River Yare in the UK'.
I have set the 1D network file. But during this process, I have changed the node levels and node number several times. When I run the 1D steady simulation, the result shows faulty initial conditions and mismatched with the 1D network DAT file.
Here is the error message:
number of labels compiled from units = 130
number of labels in data file at line 2 = 132
  2. label(node) BW32D(101) occurs in the initial conditions but not in the network
 - this is not permitted
  3. label(node) BW50U(114) occurs in the initial conditions but not in the network
 - this is not permitted
  4. label(node) BW14U(115) occurs only once (i.e. is not connected) - this is not permitted
 Datafile line   6413:
 *** error   E1057 *** at label:
 Number of errors found in node labels is   4
 stopped in reader
Could you please suggest me how will I solve this problem?
Thanks in advance for your time.
With regards,

Culverts in 2D domain

Posted 25/07/2016 09:06 by dpender

Last post 01/08/2016 10:30

2 replies


I'm relatively new to 2D modelling with Flood Modeller and was wondering if there is a way to embed 1D culverts into a 2D domain (similar to TUFLOW and Infoworks). It seems that a flow 1D-2D link line would do the job (like an SX line) but I can't find anything that explains how to link to the relevant 1D elements.

Any info greatly appreciated.


1D-2D Link Model Run

Posted 13/07/2016 11:23 by rohan

Last post 13/07/2016 11:54

2 replies



We are currently working on a project which involves 2 parallel streams channel separated by floodplain area of around 40m to 60m. Can you please suggest which of the following approaches be more suitable using Flood Modeller / ISIS Tuflow


  • Modelling both the streams in 1D and Floodplain between the two stream as 2D cell.
  • Modelling both the stream in 1D and connecting them with lateral spills
  • Which combination of software’s be better in terms of handling model stability in : 1D-2D Flood Modeller vs ISIS-Tuflow 1D-2D


We would appreciate your advice on the above.


Thanks & Regards



Direct Rainfall and Double Precision

Posted 03/06/2016 08:55 by Scott999

Last post 07/06/2016 08:21

1 reply

The ADI solver

I have an area that I am attempting to simulate surface water run-off resulting from a direct rainfall input.  The area is steeply sloping and an elevations are typically between 120mAOD and 90mAOD. The ground grid is a 1m LiDAR DTM.

Following the advice, the timestep (Δt) is between 0.25 and 0.5 the grid size i.e. 0.25 second say.

Using the ATI solver, my mass balance error is very significant so I have concerns about the accuracy of the results grids.

Further reading of the Flood Modeller manual suggest that the problem is associated with the elevations and rainfall depths.

if running in single precision, it can be an issue if the rainfall rate R, in mm/hour, is (approximately) less than 0.5z/Δt, where z is a typical ground elevation. For example, if z≈100m, and the time step is 1s, any rainfall with an intensity of less than 50mm/hr may be subject to significant mass balance errors.

I would like to run in double precision but can only find the executable in the \bin folder as ISIS2D_DP.   Attempting to Run this by double clicking opens DOS window but then gives some error and closes.   How do you run a double precision 2D model?




Water flow drastically higher for larger grid size

Posted 31/05/2016 22:05 by apeech

Last post 31/05/2016 22:37

1 reply

Please look at the following images:



As noted above each image, the grid size was changed each time the simulation was run. Absolutely nothing else changed, the flow rate coming in is the same in each flood scenario, time step is set at 1 second.

Why is there a drastically different amount of water flowing across the property when higher grid size is selected? If I lower the grid size even more, there is even less water coming across the property. I'm not sure which I'm supposed to clam is an accurate depiction of water in the flood scenario....

There is a green polyline (exit boundary) at the edge of the property. With the smaller grid size, is more water draining outside of the active area?

Edges of a computational domain

Posted 24/05/2016 14:09 by Shrestha

Last post 25/05/2016 11:40

3 replies

Hello everyone,

I'm wondering how FloodModeller is dealing with the edges of a computational domain. It seems that the model is accumulating water at the lowest-lying edges. Is it true? Do one has to define a Boundary condition along the edges to allow water to flow out of the domain through the edges of the computational domain?

Thank you in advance.


Best Regards,



Sign in to create or reply to forum posts.

Privacy & Terms